ocaml.xml 1.5 KB
Newer Older
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
<?xml version="1.0" encoding="ISO-8859-1" standalone="yes"?>
<page name="ocaml">

<title>OCaml + CDuce</title>

<left>
<local-links href="index,documentation"/>
</left>

<box>

<p>
OCaml+CDuce is a modified version of OCaml 3.08.2 with CDuce
extensions (expressions, types, patterns).
</p>

<p>
See the <a
href="http://pauillac.inria.fr/~frisch/ocamlcduce/doc/README.cduce">README.cduce</a>
file for more information, The sub-directory <tt>tests/</tt> has some
simple examples.  There is also an ocamldoc-generated documentation
for the <a href="http://pauillac.inria.fr/~frisch/ocamlcduce/doc/">support library</a>.
</p>

<p>
The package contains a bootstrapped compiler. The build procedure is
the same as for OCaml (<tt>configure, make world, make install</tt>).
</p>

<ul>
<li><a
32
33
href="http://pauillac.inria.fr/~frisch/ocamlcduce/download/cduce-ocaml-0.0.4.tar.gz">Compiler,
version 0.0.4</a></li>
34
<li><a
35
36
href="http://pauillac.inria.fr/~frisch/ocamlcduce/download/xml-support-0.0.3.tar.gz">Support
library, version 0.0.3</a></li>
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
</ul>

<p>
GODI users can upgrade an existing installation by adding this
line to their <tt>etc/godi.conf</tt> file:
</p>
<sample>
GODI_BUILD_SITES += http://pauillac.inria.fr/~frisch/ocamlcduce/godi
</sample>
<p>
and by forcing a recompilation of the <tt>godi-ocaml-src</tt>
and <tt>godi-ocaml</tt> packages. They should also build
the <tt>godi-xml-support</tt> library.
</p>

<p>
Some simple examples can be found <a href="http://pauillac.inria.fr/~frisch/ocamlcduce/tests/">here</a>.</p>

</box>

</page>