Commit d10ca846 authored by Kim Nguyễn's avatar Kim Nguyễn
Browse files

Fine tune dependencies in .opam files.

parent b48028b1
depends: [
"ocaml" {>= "4.07.0"}
"dune" {build & >= "2.8"}
"odoc" {with-doc}
"num" {>= "1.4"}
]
depends: [
"ocaml" {>= "4.07.0"}
"dune" {build & >= "2.8"}
"cduce-types"
"odoc" {with-doc}
("ocurl" { >= "0.9.1" } |
"ocamlnet" { >= "4.1.8"})
("ocaml-expat" {>= "1.1.0" } |
"pxp" {>= "1.2.9"})
]
depopts: [
"ocaml-compiler-libs" {>= "0.11.0"}
]
......@@ -3,5 +3,6 @@
(public_name cduce)
(package cduce)
(libraries cduce-types cduce.lib)
(modes byte native)
)
......@@ -2,6 +2,7 @@
(name cduce_lib)
(public_name cduce.lib)
(library_flags (-linkall))
(modes byte native)
(libraries
cduce-types
cduce.lib.core
......
opam-version: "2.0"
name: "cduce"
version: "0.7.0-rc3"
synopsis: "Modern XML-oriented functional language with innovative features"
maintainer: "https://github.com/ocaml/opam-repository/issues"
authors: "Alain Frisch"
license: "MIT"
homepage: "http://www.cduce.org/"
bug-reports: "https://gitlab.math.univ-paris-diderot.fr/cduce/cduce/-/issues"
depends: [
"ocaml" {>= "4.07.0"}
"ocamlfind"
"pcre"
"sedlex"
"ocamlnet"
"pxp"
"ocaml-compiler-libs"
"num"
"ocurl"
"ocaml-expat"
]
flags: light-uninstall
build: [
["./configure" "--prefix=%{prefix}%" "--mandir=%{doc}%/cduce"]
[make "-j" "%{jobs}%" "all"]
]
install: [make "install"]
remove: [make "uninstall"]
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment