Commit f2640290 authored by Pietro Abate's avatar Pietro Abate
Browse files

[r2003-10-08 08:01:58 by cvscast] Empty log message

Original author: cvscast
Date: 2003-10-08 08:01:58+00:00
parent 6ec173ac
...@@ -13,17 +13,17 @@ Prerequisites ...@@ -13,17 +13,17 @@ Prerequisites
Before compiling CDuce, you need to install recent releases of the Before compiling CDuce, you need to install recent releases of the
following packages: following packages:
ocaml => 3.07 ocaml => 3.07
http://caml.inria.fr/ocaml/distrib.html http://caml.inria.fr/ocaml/distrib.html
findlib findlib => 0.8
http://www.ocaml-programming.de/packages http://www.ocaml-programming.de/packages
ulex ulex => 0.3
http://www.cduce.org/download http://www.cduce.org/download
pcre-ocaml pcre-ocaml => 5.03
http://www.ai.univie.ac.at/~markus/home/ocaml_sources.html http://www.ai.univie.ac.at/~markus/home/ocaml_sources.html
ocamlnet ocamlnet => 0.94
http://sourceforge.net/projects/ocamlnet http://sourceforge.net/projects/ocamlnet
pxp => 1.9.93 pxp => 1.9.93
http://www.ocaml-programming.de/packages/documentation/pxp/index_dev.html http://www.ocaml-programming.de/packages/documentation/pxp/index_dev.html
Important notes: Important notes:
...@@ -41,8 +41,8 @@ Important notes: ...@@ -41,8 +41,8 @@ Important notes:
cvs -d":pserver:anoncvs@camlcvs.inria.fr:/caml" co ocaml cvs -d":pserver:anoncvs@camlcvs.inria.fr:/caml" co ocaml
- pcre-ocaml: you may also need to install the PCRE library - pcre-ocaml: you may also need to install the PCRE library
from http://www.pcre.org/ [red-hat users: 4.3 package does from http://www.pcre.org/ [red-hat users: 4.2 and 4.3 packages
not work with the latest pcre-ocaml version, use tarballs] do not work with the latest pcre-ocaml versions, use tarballs]
>= 5.03 recommended but previous versions may work >= 5.03 recommended but previous versions may work
- PXP: - PXP:
...@@ -63,6 +63,14 @@ Efficiency issues: ...@@ -63,6 +63,14 @@ Efficiency issues:
Compilation Compilation
------------------------------------------------------------------------------ ------------------------------------------------------------------------------
THE FAST WAY:
- check the setting in Makefile.conf [optional]
- make all && make install
THE WISE WAY:
You need a GNU Make (or equivalent) to use the Makefile from the You need a GNU Make (or equivalent) to use the Makefile from the
distribution. It defines the following goals: distribution. It defines the following goals:
...@@ -91,6 +99,9 @@ distribution. It defines the following goals: ...@@ -91,6 +99,9 @@ distribution. It defines the following goals:
cduce.1 into $(PREFIX)/man/man1 cduce.1 into $(PREFIX)/man/man1
(see PREFIX below) (see PREFIX below)
- make clean
back to the starting point
Makefile accepts the following options. Makefile accepts the following options.
NATIVE=true : use the OCaml native code compiler (ocamlopt) to build CDuce NATIVE=true : use the OCaml native code compiler (ocamlopt) to build CDuce
...@@ -107,7 +118,7 @@ PREFIX=/usr/local by default: where to install CDuce files (see ...@@ -107,7 +118,7 @@ PREFIX=/usr/local by default: where to install CDuce files (see
Makefile.conf) Makefile.conf)
E.g.: E.g.:
make cduce NATIVE=false make cduce NATIVE=false PREFIX=/usr/share
You can also modify Makefile.conf to set values for these choices. You can also modify Makefile.conf to set values for these choices.
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment